This is a common error to notify you that your version of Kontakt is out dated.

Please update your version of Kontakt to the latest version which is accessible through the Native Instruments Service center